SQLSTATE [HY000]

1.29K
.
Hey guys! Finally I'm gonna change status!🐯
Simba, Проверь расширение у него
if (extension_loaded('mysqlnd')) { echo 'Загружен mysqlnd'; exit;}
Если собрано с libmysql то никак нативные данные не получишь, только приводить типы.
.
Кадило крутится, лавэха мутится
# kantry (17.02.2020 / 16:51)
Simba, Проверь расширение у него
if (extension_loaded('mysqlnd')) { echo 'Загружен mysqlnd'; exit;}
Если собрано с libmysql то никак нативные данные не получишь, только приводить типы.
mysqlnd есть у него, но походу используется не оно.
.
Менделеев
Где ресселером выступаешь там сервер собирал ?
.
kantry
Hey guys! Finally I'm gonna change status!🐯
Simba, Узнать что используется можно из pdo var_dump($db->getAttribute(PDO::ATTR_CLIENT_VERSION));
Это у меня ludes/index.php:30:string 'mysqlnd 7.4.2' (length=13)
.
Кадило крутится, лавэха мутится
# kantry (17.02.2020 / 16:59)
Simba, Узнать что используется можно из pdo var_dump($db->getAttribute(PDO::ATTR_CLIENT_VERSION));
Это у меня ludes/index.php:30:string 'mysqlnd 7.4.2' (length=13)
string(14) "5.5.64-MariaDB"
.
kantry
Hey guys! Finally I'm gonna change status!🐯
Simba, Блеать, как все запущено Сейчас на джино гляну, там тоже мария))
На хостинге джино у меня
string(79) "mysqlnd 5.0.12-dev - 20150407 - $Id: 3591daad22de08524295e1bd073aceeff11e6579 $"
.
kantry, разве на джино только 5.0?
.
Кадило крутится, лавэха мутится
# Microb (17.02.2020 / 17:14)
kantry, разве на джино только 5.0?
Не, это версия драйвера, она норм.
.
Hey guys! Finally I'm gonna change status!🐯
Microb, Это не mysql, это версия клиента базы данных(pdo)
.
Hey guys! Finally I'm gonna change status!🐯
Simba, А у него что за хостинг? Это уже второй случай, похоже у партизана такая же хрень. Придется насильно типы приводить
Всего: 54